Armenian Knowledge Base  

Go Back   Armenian Knowledge Base > Technical sections > Operating Systems > Unix
Register

Reply
 
LinkBack Thread Tools
Old 22.08.2004, 00:49   #1
Полная бяка
 
Immortal's Avatar
 
Join Date: 05 2004
Location: Yerevan
Age: 32
Posts: 6
Downloads: 0
Uploads: 0
Reputation: 0 | 0
Unhappy Genius modem problem, help:(

Называется решил поменять себе модем на такой, который бы и с Линуксом работал... Купил Genius GM56E-V2 так как и в списке поддерживаемого hard-а (Linux Mandrake 9.1, http://www.mandrakelinux.com/en/hard...modem&F_ID=457 и в списке на http://www.devidal.tv/~chris/winmodems/dips/roster.html чипсет модема (Topic 560x) поддерживается. После установки он начал(!) звонить, но после первого же раза написал Can't establish a connection и сдох. Теперь дозвон вообще не производится из под Линукса. В Вине все работает. Плиз, помогите заставить его работать, если это возможно, порт подсоединения Com1. В логах нашел только это:
Code:
02:36:58 drakconnect[2710]: ### Program is starting ###
02:37:13 net_monitor.real[2739]: ### Program is starting ###
02:37:15 net_monitor.real[2739]: launched command: /etc/sysconfig/network-scripts/net_cnx_up &
02:37:50 net_monitor.real[2739]: launched command: /etc/sysconfig/network-scripts/net_cnx_up &
А это из модемовских логов Вина:

Code:
ATQ0V1E0 - OK
AT+GMM - COMMAND NOT SUPPORTED
AT+FCLASS=? - 0,1,8
AT#CLS=? - COMMAND NOT SUPPORTED
AT+GCI? - COMMAND NOT SUPPORTED
AT+GCI=? - COMMAND NOT SUPPORTED
ATI1 - External Controller Ver3.00, CheckSum=B837
ATI2 - TEST OK!
ATI3 - Genius GM56E-V2 External PnP Modem
ATI4 - DSP Ver3.00 CheckSum=769B
ATI5 - United States
ATI6 - 0
ATI7 - Controller Ver3.00 Date:Nov 06 16:26 2001
Заранее спасибо.
Reply With Quote
Old 24.08.2004, 17:19   #2
Guru Apprentice
 
Join Date: 02 2002
Location: /dev/null
Age: 41
Posts: 524
Downloads: 0
Uploads: 0
Reputation: 0 | 0
Default

Интересно как-то у тебя получается, позвонил один раз - и больше не звонит...
Ладно, вот что нужно: есть ли у тебя программа minicom? Если есть - запусти как root, настрой правильно порт (кажется /dev/ttyS0) и попробуй сказать модему AT (он должен сказать OK). Ну вобщем пройдись по тем же АТ коммандам, на которые твой Windows лог нормальные вещи говорит.

Mandrake я к сожалению не знаю, но дальше можно будет потихонечку разбираться.
Reply With Quote
Reply

Thread Tools


На правах рекламы:
реклама

All times are GMT. The time now is 07:32.


Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.